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About this guide  

This guide is designed to provide a quick introduction to Promodag Reports for Microsoft 
Exchange, and it describes steps from getting started to producing the first report.  

For more details about specific features of Promodag Reports, please refer to the online Help 
system.  

  

Introducing PROMODAG Reports  

PROMODAG Reports is an advanced and cost-effective reporting tool that enables 
administrators and IT managers to obtain valuable information about all aspects of their email 
system. 

With its powerful and easy-to-understand features, PROMODAG Reports produces 
comprehensive reports that you can rely on to ensure better security, business continuity, and to 
get a better understanding on the email activity within your organization. 

PROMODAG Reports is easy to install and configure. Reports use native Office 365 data 
sources. The product collects and stores the necessary data into an Access or SQL Server 
database. You can choose from over 30 ready-made report templates and publish reports to 
various destinations in different formats. All operations can be easily automated and scheduled 
so you can set up the product and forget about it.  
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How does it work? 

Promodag Reports collects the information it needs from your Office 365 tenant and stores it into 
a database. 

• Traffic reports are based on message tracking files created by the application on the 
console, and then imported into the database.  

• Inventory reports are based on the information retrieved during directory import.  

• Storage size reports (growth, comparison) are based on imported storage size data.  

Office 365 environments: schematic system 
layout 
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Chapter 1 - Prerequisites 

• Workstation requirements 

• Required permissions 

• "Creating a Promodag account in your Office 365 tenant", on page 6 

• Creating the Promodag account in an On-Premises environment 

• "SQL Server requirements for Promodag Reports Enterprise edition", on page 7 

• Exchange 2013/2016: Creating an Outlook profile and disabling Cached Exchange Mode 

• What is the impact on Exchange server performance ? 

A - Workstation requirements 

The 'Promodag workstation' is the computer on which Promodag Reports is installed.  

Promodag Reports can be installed on a machine running a supported desktop or server operating 
system. It is not recommended to install it on a strategic element of your environment, for example a GC 
server or an Exchange server. 

Workstation hardware and software requirements  

• Computer: A Core i3 Intel Processor with 4 GB of RAM or an equivalent Virtual Machine.  

• Disk space: Sufficient disk space to store the database. 

• Supported operating systems: Windows Vista/Windows Server 2008 to Windows 10/Windows 
Server 2016 (32 or 64-bit). 

B - Creating a Promodag account in your Office 365 tenant 

Promodag Reports needs an account with sufficient permissions to collect information from your Office 
365 tenant. It is possible to use an existing account; however, we recommend creating a dedicated 
account for that purpose. 

1. Create a user account 

• Sign in to Office 365. 

• Go to the Office 365 Admin Center. 

• On the Home page, choose Add a user. 

• Choose a Display name and a user name. 

2. Assigning the relevant admin role(s) to the Promodag account 

• Sign in to Office 365. 

• Go to the Office 365 Admin Center. 

• Click Admin > Exchange to open the Exchange Admin Center. 

• Click Permissions and open the Admin role tab. 

• Click to open the View-Only Organization Management role group.  

• Click + to add the Promodag account. 

• Click Save. 

We recommend that the new user account be added to the View-Only Organization Management role 
group.  
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If this permission level is too high for your company's requirements, you can replace it with Recipient 
Management and Helpdesk.  

3. Allowing multi-factor authentication (MFA) 

If your admin has turned on multi-factor authentication for your organization, you will need to generate an 
app password so Promodag Reports can connect to Office 365.  

B - How to create an app password 

• Sign in to Office 365. 

• Choose Settings Office 365 > Office 365. 

• Choose Security & Privacy > Additional security verification.  

• Choose Additional security verification. 

• Choose Update my phone numbers used for account security. 

• Choose app passwords. At the top of the page, choose App Passwords. 

• Choose create to get an app password. If prompted, type a name for your app password, and click 
Next. 

• Choose copy password to clipboard. You won't need to memorize this password. 

• Choose copy to your clipboard. 

Then open Promodag Reportsand paste the app password in the Office 365 configuration tab of Tools > 
Options. 

C - SQL Server requirements for Promodag Reports 
Enterprise edition 

1. Supported versions  

Promodag Reports supports Microsoft SQL Server 2005 to SQL Server 2016 (32 or 64-bit). 

SQL Server Express (2005 to 2016) may be used with Promodag Reports Enterprise edition; however, 
database size is limited depending on the version (10 GB for SQL Server 2008 R2/2016 Express and 4 
GB for SQL Server 2005/2008 Express).  

2. Permissions  

The Promodag account must have been granted the db_owner role on the Promodag Reports database. 
It must also have the public and db_datareader roles on the TEMPDB database. 

The ability to create databases requires specific SQL permissions (CREATE DATABASE). 

Chapter 2 - Getting started 

A - Evaluating the product 

You may evaluate Promodag Reports for a period of up to 45 days from first installation. The only other 
limitation is that your reports on e-mail traffic can only cover a maximal period of 15 consecutive days. 

../../../Content/Topics/Interface/Tools_Options_Office_365_configuration.htm
../../../Content/Topics/Interface/Tools_Options_Office_365_configuration.htm
../../../Content/Topics/Presentation/Licensing_schema.htm
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You can indeed only import up to 15 consecutive days of Office 365 message tracking files in evaluation 
mode, which explains the latter restriction. 

There is no limitation to the number of report templates you can use - all options being available, during 
your 45-day evaluation period. 

B - Installing the application 

Note: Please make sure that your workstation complies with all points listed in Workstation requirements 
before proceeding with the installation process. 

Installing Promodag Reports 

a. Go to https://www.promodag.com/ to download PROMODAG Reports. 
b. Choose a temporary directory to store the installation package. 
c. Double-click the installation package to start the installation process. 
d. Simply follow the instructions of the installation wizard. 

For more information about default paths for installation and settings, see the help file. 

C - Initial setup 

Starting the application 

From the Start Menu, select Programs > Promodag > PROMODAG Reports 10 to start Promodag 
Reports. 

The configuration wizard provides a user-friendly interface to start with PROMODAG Reports. It 
automatically appears when you run the software for the first time, and guides you through the first 
configuration of the product. 

https://www.promodag.com/
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It provides you with instructions on: 

1. Evaluating or licensing the product, 
2. Creating a new Promodag Reports database, 
3. Configuring a connection to your Office 365 tenant, 
4. Selecting data sources for traffic and storage size reports,  
5. Starting the data import process. 

1. Evaluating or licensing the product 

This window lets you carry on using Promodag Reports in evaluation mode, or apply a valid license to the 
database. 

 

../../../Content/Topics/Interface/Msg_License_Evaluation.htm
../../../Content/Topics/Interface/Starting_Wizard-Search_License.htm
../../../Content/Topics/Interface/Starting_Wizard-Search_License.htm
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2. Creating a new Promodag Reports database 

Promodag Reports requires a database in order to store the data it collects from Microsoft Exchange. It 
will then use this data to generate reports. It is possible to create multiple databases.  

To create a new database, select the type of your messaging environment, and the type of database that 
best suits your needs. 

Exchange Organization type 

• Office 365: The messaging system is hosted by Microsoft. Microsoft Exchange Online is an email, 
calendar and contacts solution delivered as a Cloud service and it is part of the Office 365 suite. 

• Hybrid deployment: Hybrid deployment is a mixed environment: part of the messaging system is 
hosted in an Office 365 tenant, but the company has kept some Exchange servers on-premise. 

• On-Premises: Administrators run the messaging system on their own servers, in their own 
company. 

Select Office 365. 

Database type 

Microsoft Access  

• Best suited for small Office 365 tenants (less than 1,000 mailboxes). 

• Usable with all editions of Promodag Reports. 

• The physical size limit set by Microsoft to Access 2000 database files is 2 GB (2,048 MB).  

• Installing Microsoft Access is not required. 

• The database file should be located on the same computer as Promodag Reports. 

Microsoft SQL Server  

• Best suited for medium or large Office 365 tenants (more than 1,000 mailboxes). 

• Requires the Enterprise edition of Promodag Reports. 

• The database size is only limited by disk space on the SQL Server.  

• Multi-user access. 

• Performance is determined by the power of the SQL server. 

• An additional SQL Server license (not provided) may be required. 

The Access format is recommended for evaluating the product, for it does not require anything else.  

Choose a name for your database. For SQL, enter the name of the server without \\, and then the name of 
the instance if applicable. 

Click the Next button to confirm your settings and move on to the next step. 

../../../Content/Topics/Presentation/Licensing_schema.htm
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3. Configuring a connection to your Office 365 tenant  

Enter the credentials of the account you created for using with the product, see "Creating a Promodag 
account in your Office 365 tenant", on page 6. 

Click the Next button to confirm your settings and move on to the next step. 
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4. Selecting data sources for traffic and storage size reports  

Data sources for traffic reports 

Promodag Reports will create and then import Office 365 message tracking files to generate traffic 
reports. Message tracking data is only available from Office 365 for the past 7 days.  

Data sources for storage size reports 

The size of mailboxes is selected by default. If you have public folders in the Cloud, select Public folder 
size. 

Click the Next button to confirm your settings and move on to the next page.  

 

5. Starting the import data process 

 Processing imports  

Click the Finish button to start importing data. The complete process includes all previously configured 
steps, and can take some time depending on your selections. 
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 Promodag Reports   

1. Imports recipients from Office 365,  
2. Creates message tracking files, 
3. Imports message tracking data, 
4. Imports storage size data. 

Each operation finishes off by displaying an operation report dialog box. A trace file is also recorded and 
can be used to troubleshoot possible errors or resolve various configuration issues. If you need to do so, 
use the Consult Trace Files option to view the content of the last trace files. 

 

 

Chapter 3 - Using reports 

../../../Content/Topics/Using_the_product/Operation_Report_Dialog_Box.htm
../../../Content/Topics/Using_the_product/Trace_Files_Content.htm


  

  

A - How to find your way? 

Promodag Reports includes about 30 report templates adapted to Office 365 that you can use to create 
your own custom reports.  

1. Report templates 

To open a template, you can either  

1. Use the Templates menu. 
2. Use the Report Explorer, on the left pane of the main window. It can be hidden or displayed by 

clicking the  icon. 

Before you start using the product, we suggest you to open our List of reports templates in the embedded 
help file. 

Templates are grouped in categories, such as Storage or Billing for example. These categories appear 
as main nodes in the Report Explorer and they cannot be modified. The names of these categories are 
meant to help you find your way among templates. Each entry comes with a short description. 

 Graphical reports are distinguished from tabular reports in the Templates menu as well as in the Report 

Explorer by a specific  icon. 

EX AMPLE  

• A template that would let you generate a report showing the size of public folders is likely to be 
found in the category called Storage. If you open that category, you will find a template called 
Public Folder Storage Information.  

• Should you likewise need to produce a report showing the top 10 email senders in your 
organization, open the category called Mailbox Traffic. If you open that category, you will find a 
template called Mailbox by Traffic Level. 

2. Canned reports (Favorites) 

The software is delivered with a number of ready-to use custom reports, for example: 'What are the 10 
largest mailboxes'. These canned reports are available on the Favorites menu and they are grouped in 
custom categories based on the main use cases of the product: Traffic Analysis and SLA Reporting, 
Compliance, Capacity Planning and Exchange Migrations, Chargeback. 

You can rename these sample reports or delete them at will. You can also rearrange the existing tree, or 
create your own hierarchy in the Favorites menu. 

B - Creating new custom reports 

1. Selecting a valid reporting period 

Period tab and data sources 

Many report templates include a Period tab: all traffic reports and some reports on storage size. These 
templates share in common the use of data that must previously be imported into the database. 

../../../Content/Topics/Reports/Definition/Definition_PRR0002.htm
../../../Content/Topics/Reports/Definition/Definition_PRR0030.htm
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What reporting period can be selected? 

The time range you select in the Period tab must always be covered by matching data imports.  

EX AMPLE  

Requesting a report on mailbox traffic for January until June last year will not work if you have only started 
to import message tracking files of this year. If you do so, you will get a message to inform you that 'No 
data was found for the selected period'. 

Note: In evaluation mode, it is only possible to import 15 days of data: as a consequence, it is also only 
possible to report on that same time period.  

For more information on the limitations of the evaluation mode, see "Evaluating the product", on page 7. 

  

2. Selecting recipients 

Selection tab and recipients 

All report templates include a Selection tab. This feature lets you include recipients whose traffic, content 
or storage must be displayed in the report.  

A recipient can be a mailbox, a distribution group, a public folder or a mail contact. 

Recipients are imported with most of their attributes into the database, which lets you select them using 
the attribute of your choice in the Selectiontab. 

EX AMPLE  

Mailboxes can be selected by Country, or Department, or Employee ID. 

 

../../../Content/Topics/Interface/Error_Messages/Msg_No_Data_available_Traffic.htm
../../../Content/Topics/Interface/Error_Messages/Msg_No_Data_available_Traffic.htm
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What recipients can be selected? 

Each report template focuses on a specific aspect of the messaging system. As a consequence, the 
available Selection tabs differ depending on the scope of the report template. 

EX AMPLE  

A report template focused on mailbox traffic will let you select mailboxes, whereas a report template 
dedicated to public folder content will let you select public folders only. 

Some transverse templates like Find Specific Messages, that is focused on messages, will let you select 
different recipient types: mailboxes, or distribution groups, or public folders. 

Excluding recipients 

Click the  button to exclude recipients from the report using the same principle. 

3. Selecting correspondents 

The 'correspondents' are those who sent messages to, or received messages from your selection of 
recipients.  

The vast majority of traffic report templates include a Correspondents tab. This feature lets you filter the 
correspondents of the recipients previously selected in the Selection tab.  

The most usually available option allow you to select correspondents by address type.  

• To select all internal correspondents, select: Administrative group, Like, * 

• To select all external correspondents, select: Internet domain, Like, * 

• To select all application agents, devices etc. that have an SMTP address but no mailbox, select: 
Unidentified local address, Like, * 

• To select all address types that are not listed above, select: Others, Like, * 
  

EX AMPLE  

You may want to select correspondents from specific SMTP domains, for example the gmail.com, yahoo 
and hotmail correspondents of the selection of mailboxes you have just checked in theSelection tab. 

 

Some specialized reports such as Find Specific Messages allow a larger selection of correspondents: not 
only is it possible to select correspondents by address type, but also by recipient type or even an 
individual SMTP address. 

4. Selecting the right detail level 

Many report templates include a Content tab with Detail level options. This feature is aimed at focusing 
the report at different levels. 

../../../Content/Topics/Reports/Definition/Definition_PRR0032.htm
../../../Content/Topics/Using_the_product/Partner_type.htm
../../../Content/Topics/Using_the_product/Partner_type.htm#Address_Types_Others
../../../Content/Topics/Reports/Definition/Definition_PRR0032.htm
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EX AMPLE  

A report template on recipient traffic such as General Mailbox Traffic includes three detail levels: Totals 
only, Recipient and Message subject line. if you select Totals only, it will merely display a cumulated total 
of all messages sent/received by the selected recipients, whereas it would display each single message if 
you had selected Message subject line. 

 

The same principle applies to all other templates that have a Detail level option: the more you go down the 
list, the more detailed the report will be. 

C - Saving custom reports 

1. Saving and reloading a report with its options 

To create and save a new custom report, select a report template from the Templates menu, and select 
the options of your choice. You may also record specific selection settings separately if you plan to reuse 
them in other reports. 

• Click the Save button at the bottom of the report interface to save the option file. 

• Click the Load button to reload it once the report interface is open. 

 

2. Adding a report to the Favorites 

Make your own custom reports available in the Favorites menu by selecting the 'Add to Favorites menu' 
check box before saving them. 

../../../Content/Topics/Interface/Menu_Templates.htm
../../../Content/Topics/Using_the_product/Selection_files.htm
../../../Content/Topics/Reports/Report_Options_Load_Save.htm
../../../Content/Topics/Reports/Report_Options_Load_Save.htm
../../../Content/Topics/Interface/Menu_Favorites.htm
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D - Previewing, exporting, publishing and e-mailing reports  

A report can either be previewed on screen, exported to various file formats, published to a SharePoint 
document library or automatically attached to an e-mail and sent to a recipient of your choice.  

1. Previewing reports 

The default output is 'Screen'. It is recommended to use it when generating a report for the first time, so 
that you can reload your options and adapt them if necessary.  

2. Exporting reports 

Use the File > Export Report option once the report is available for preview on screen.  

Available formats 

Reports can be exported to different file formats: CSV, PDF, XLS, XLSX, RTF, HTML, MHT. 

3. Publishing reports 

You can export reports  

• To your Intranet: Export reports as PDF or HTML files to the web root of your intranet. 

• To a public folder: Select the 'Exchange folder' output option. 

../../../Content/Topics/Interface/File_Export_Report.htm
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• To SharePoint: Select the SharePoint output option. The default server and document library can 
be selected in the Export tab of Tools > Options. 

4. E-mailing reports 

All reports can be emailed to specific recipients, by selecting the Email output option. Moreover, the 
Compose For... tab allows you to email reports to all mailboxes selected in the report. 

Support 

This page provides an overview of Promodag’s support resources for our existing users and newcomers 
evaluating the product. Alongside a suite of on-line resource tools focused on addressing common user 
issues, we also provide a dedicated support system.   

Self-help resources  

The quickest starting point for your support needs is to consult our on-line resource tools on our support 
page (https://www.promodag.com/support). 

Submitting a Support Request 

Our customer support team will respond to requests from both users evaluating the product and 
customers with a valid maintenance contract.  

Support requests can be submitted either … 

• Via our contact form: https://www.promodag.com/contact-us/ 

• Via email at support@promodag.com or use Help > Technical Support Request from the product’s 
menu system. 

• Or by phone: +33 1 53 27 66 60 or Toll Free (from USA only): 1(888) 696-5404. 

We normally respond within 2 hours, but please allow 24 hours for us to respond to account for 
differences in international time zones. 

../../../Content/Topics/Interface/Tools_Options_Export.htm
../../../Content/Topics/Reports/ComposeFor/ComposeFor_Standard.htm
https://www.promodag.com/support/
https://www.promodag.com/support/
https://www.promodag.com/contact-us/
mailto:support@promodag.com?subject=Support%20request%20for%20PROMODAG%20Reports
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