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About this guide
This guide is designed to provide a quick introduction to Promodag Reports for Microsoft
Exchange, and it describes steps from getting started to producing the first report.
For more details about specific features of Promodag Reports, please refer to the online Help
system.

Introducing Promodag Reports
Promodag Reports is an advanced and cost-effective reporting tool that enables Exchange
Server administrators and IT managers to obtain valuable information about all aspects of their
email system.
With its powerful and easy-to-understand features, Promodag Reports produces comprehensive
reports that you can rely on to ensure better security, business continuity, and to improve
Exchange organization performance.
Promodag Reports is easy to install and configure. Reports use native Exchange server data
sources; so there is nothing to install on the server. The product collects and stores the
necessary data into an Access or SQL Server database. You can choose from over 80 readymade report templates and publish reports to various destinations in different formats. All
operations can be easily automated and scheduled so you can set up the product and forget
about it.

Getting started with Promodag Reports

5

How does it work?
Promodag Reports collects the information it needs from different native Exchange data sources.
•
•
•
•

Traffic reports are based on Exchange message tracking files previously imported into
the database.
OWA and ActiveSync reports are based on IIS log files previously imported into the
database.
Inventory reports are likewise based on the information retrieved during directory import.
On the other hand, all reports on mailbox/public folder content directly take their
information from Exchange through a dynamic MAPI connection. Storage size reports
(growth, comparison) are based on imported storage size data.

On-premises environments: schematic system
layout
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Office 365 environments: schematic system
layout

Chapter 1 - Prerequisites

A - Microsoft Exchange Server requirements
Promodag Reports supports Microsoft Exchange Server 2007 to Exchange Server 2016 and Office 365
(Exchange Online). It is possible to use the product with a mix of different versions of Exchange.
You do not need to install anything on the Exchange Server, or to modify anything in your
Exchange organization.

B - Workstation requirements
The 'Promodag workstation' is the computer on which Promodag Reports is installed.
Promodag Reports can be installed on a machine running a supported desktop or server operating
system. It is not recommended to install it on a strategic element of your environment, for example a GC
server or an Exchange server.

1. Workstation hardware and software requirements
•
•
•
•
•

Computer: A Core i3 Intel Processor with 4 GB of RAM or an equivalent Virtual Machine.
Disk space: Sufficient disk space to store the database.
Supported operating systems: Windows Server 2008 R2 to Windows 10/Windows Server 2016 (32
or 64-bit).
Software Framework: .NET Framework 4.7
MAPI (on-premises organizations only, may be replaced by EWS):
Version of Outlook

Outlook 2016 (32-bit)

Exchange
2016

Exchange
2013

Exchange
2010

Exchange
2007

X

Outlook 2013 (32-bit)

X

Outlook 2010 (32-bit)

X

Outlook 2007 (32-bit)
Exchange MAPI and CDO
1.2.1

X
x

x

2. Additional requirements
The Windows Remote Management (WS-Management) service should be enabled and set to Automatic
(Delayed Start). If your Exchange organization is Hybrid or full Office 365, the computer must have access
to the Internet.

C - Creating a Promodag account for an On-Premises
environment
The 'Promodag account' is the service account that is used to start Promodag Reports. It should be
created along with a mailbox.

1. Create a user account and a mailbox
Create a new user and a mailbox using the Exchange admin center (EAC) and give it a meaningful name,
for example 'ServicePromodag'. The password for this user should never expire.

2. Add the user to the right Exchange management role groups
Exchange 2013/2016:
•
•

In the Exchange Administration Center (EAC), navigate to Permissions > Admin Roles.
Select the Organization Management role group, and then click Edit.
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•
•

In the Members section, click Add. Select the users, USGs, or other role groups you want to add to
the role group, click Add, and then click OK.
Click Save to save the changes to the role group.

We recommend that the new user account be added to the Organization Management role group.
If this permission level is too high for your company's requirements, you can replace it with Recipient
Management and Public Folder Management.
Adding Impersonation rights to the Promodag account (EWS):
•
•
•
•
•

In the Exchange Administration Center (EAC), navigate to Permissions > Admin Roles.
Double-click the Discovery Management role group to edit it.
Click + to add the ApplicationImpersonation role to this role group.
Click + to add the Promodag account to this role group.
Click Save.

Exchange 2010:
Add the user account into the Organization Management role group using Active Directory Users and
Computers tool (ADUC). You will find this group in the Microsoft Exchange Security Group Organizational
Unit.

Exchange 2007:
•
•
•

Start the Exchange Management Console tool.
Right-click Organization Configuration and select the Add Exchange Administrator option.
Select the user account used to start Promodag Reports (or the account defined in Server
Properties, Security tab and set its role to Exchange View-Only Administrator.

3. Add the user to the local Administrators group
Follow these steps to add the Promodag account to the local Administrators group:
1.
2.
3.
4.

Open Computer Management.
In the console tree, click Groups (Computer Management\System Tools\Local Users and
Groups\Groups).
Right-click the Administrators group, click Add to Group , and then click Add .
In the Select Users, Computers, or Groups dialog box, type the name of the Promodag account,
and then click OK .

D - Creating a Promodag account for your Office 365 tenant
Promodag Reports needs an account with sufficient permissions to collect information from your Office
365 tenant. It is possible to use an existing account; however, we recommend creating a dedicated
account for that purpose.

1. Create a user account for Promodag Reports
You must log on to Office 365 as an administrator to perform this task.
•
•
•
•

Sign in to Office 365.
Go to the Office 365 Admin Center.
On the Home page, choose Add a user.
Choose a Display name and a user name.

Getting started with Promodag Reports

2. Assigning the View-Only Organization Management admin role to the
Promodag account
•
•
•
•
•
•
•

Sign in to Office 365.
Go to the Office 365 Admin Center.
Click Admin > Exchange to open the Exchange Admin Center.
Click Permissions and open the Admin role tab.
Click to open the View-Only Organization Management role group.
Click + to add the Promodag account.
Click Save.

We recommend that the new user account be added to the View-Only Organization Management role
group.
If this permission level is too high for your company's requirements, you can replace it with Recipient
Management and Helpdesk.

3. Adding Impersonation rights to the Promodag account (EWS)
•
•
•
•
•
•
•
•

Sign in to Office 365.
Go to the Office 365 Admin Center.
Click Admin > Exchange to open the Exchange Admin Center.
Click Permissions and open the Admin role tab.
Double-click the Discovery Management role group to edit it.
Click + to add the ApplicationImpersonation role to this role group.
Click + to add the Promodag account to this role group.
Click Save.

4. Allowing multi-factor authentication (MFA)
If your admin has turned on multi-factor authentication for your organization, you will need to generate an
app password soPromodag Reportscan connect to Office 365.

D - How to create an app password
•
•
•
•
•
•
•
•
•

Sign in to Office 365.
Choose Settings > Office 365.
Choose Security & Privacy > Additional security verification.
Choose Additional security verification.
Choose Update my phone numbers used for account security.
Choose app passwords. At the top of the page, choose App Passwords.
Choose create to get an app password. If prompted, type a name for your app password, and click
Next.
Choose copy password to clipboard. You won't need to memorize this password.
Choose copy to your clipboard.

Then openPromodag Reports and paste the app password in theOffice 365 configuration tab of Tools >
Options.
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E - SQL Server requirements for Promodag Reports
Enterprise edition
1. Supported versions
Promodag Reportssupports all editions of Microsoft SQL Server 2008 to SQL Server 2017 (32 or 64-bit
versions).
SQL Server Express (2008 to 2017) may be used withPromodag ReportsEnterprise edition; however,
database size is limited depending on the version (10 GB for SQL Server 2008 R2/2017 Express and 4
GB for SQL Server 2008 Express).

2. Permissions
The Promodag account must have been granted the db_owner role on the Promodag Reports database.
It must also have the public and db_datareader roles on the TEMPDB database.
The ability to create databases requires specific SQL permissions (CREATE DATABASE).

Chapter 2 - Getting started

A - Evaluating the product
You may evaluate Promodag Reports for a period of up to 45 days from first installation. The only other
limitation is that your reports on e-mail traffic or OWA and Active Sync activity can only cover a maximal
period of 15 consecutive days.
You can indeed only import up to 15 consecutive days of Exchange message tracking files or IIS log files
in evaluation mode, which explains the latter restriction.
There is no limitation to the number of report templates you can use - all options being available - during
your 45-day evaluation period.

B - Installing the application
Note: Please make sure that your workstation complies with all points listed in "Workstation
requirements", on page 7 before proceeding with the installation process.

Installing Promodag Reports
a.
b.
c.
d.

Go to https://www.promodag.com/ to download PROMODAG Reports.
Choose a temporary directory to store the installation package.
Double-click the installation package to start the installation process.
Simply follow the instructions of the installation wizard.

For more information about default paths for installation and settings, see the help file.

C - Initial setup
Starting the application
From the Start Menu, select Programs > Promodag > PROMODAG Reports 10 to start Promodag
Reports.
You will first be prompted to select the type of Exchange organization you wish to analyze.
The configuration wizard provides a user-friendly interface to start with PROMODAG Reports. It
automatically appears when you run the software for the first time, and guides you through the first
configuration of the product.
It provides you with instructions on:
1.
2.
3.
4.
5.

6.

Evaluating or licensing the product,
Creating a new PROMODAG Reports database,
Configuring a connection to the directory,
Configuring a connection to your Office 365 tenant (Hybrid deployment),
Selecting data sources to import depending on the reports you need:
a. Message tracking files,
b. Internet Information Services log files,
c. Storage size:
• Mailbox size,
• Database size,
• Mailbox count per database,
• Public folder size,
Starting the data import process.

1. Evaluating or licensing the product
This window lets you carry on using Promodag Reports in evaluation mode, or apply a valid license to the
database.

2. Creating a new Promodag Reports database
Promodag Reports requires a database in order to store the data it collects from Microsoft Exchange. It
will then use this data to generate reports. It is possible to create multiple databases.
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To create a new database, select the type of your messaging environment, and the type of database that
best suits your needs.

Exchange Organization type
•
•
•

On-Premises: Administrators run the messaging system on their own servers, in their own
company.
Hybrid deployment: This is a mixed environment: part of the messaging system is hosted in an
Office 365 tenant, but the company has kept some Exchange servers on-premise.
Office 365: The messaging system is hosted by Microsoft. Microsoft Exchange Online is an email,
calendar and contacts solution delivered as a Cloud service and it is part of the Office 365 suite.

Select On-Premises or Hybrid deployment depending on your messaging environment.

Database type
Microsoft Access
•
•
•
•
•

Best suited for small Office 365 tenants (less than 1,000 mailboxes).
Usable with all editions of Promodag Reports.
The physical size limit set by Microsoft to Access 2000 database files is 2 GB (2,048 MB).
Installing Microsoft Access is not required.
The database file should be located on the same computer as Promodag Reports.

Microsoft SQL Server
•
•
•
•
•
•

Best suited for medium or large Office 365 tenants (more than 1,000 mailboxes).
Requires the Enterprise edition of Promodag Reports.
The database size is only limited by disk space on the SQL Server.
Multi-user access.
Performance is determined by the power of the SQL server.
An additional SQL Server license (not provided) may be required.

The Access format is recommended for evaluating the product, for it does not require anything else.
Choose a name for your database. For SQL, enter the name of the server without \\, and then the name of
the instance if applicable.
Click the Next button to confirm your settings and move on to the next step.

Getting started with Promodag Reports
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3. Configuring a connection to the directory
Note: This step does not appear if you have chosen to analyze a type of organization that does not
requires a connection to the directory, that is 'Office 365'.
Promodag Reports attempts to automatically discover a Global Catalog server, and then to establish a
connection using LDAP.
The product needs specific permissions to connect to the directory to retrieve the structure of the
Exchange organization, and all Exchange-related objects. Click the Next button to confirm your settings
and move on to the next step.

4. Configuring a connection to your Office 365 tenant
Enter the credentials of the account you created for using with the product, see "Creating a Promodag
account for your Office 365 tenant", on page 8.
Click the Next button to confirm your settings and move on to the next step.
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5. Selecting data sources to import depending on the reports you need
Message tracking files
Promodag Reports will use this data source to generate traffic reports. Select the servers whose message
tracking files will be imported. The default date range covers the last 7 days.
You may specify the period to be imported:
•
•

Import from: Date of the first message tracking file to import.
To: Date of the last message tracking file to import.

Click the Next button to confirm your settings and move on to the next page. The location of message
tracking files will be tested on each selected server.
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IIS log files
Promodag Reports will use this data source to generate OWA and ActiveSync reports. Select the servers
whose IIS log files will be imported. The default date range covers the last 7 days.
You may specify the period to be imported:
•
•

Import from: Date of the first message tracking file to import.
To: Date of the last message tracking file to import.

Click the Next button to confirm your settings and move on to the next page. The location of IIS log files
will be tested on each selected server.
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Storage size
Promodag Reports will use this data source to generate storage size reports. Select the servers whose
storage size (mailbox and public folder size, Exchange database size) will be imported.
Click the Next button to confirm your settings and move on to the next page. The location of mailbox and
public folder databases will be tested on each selected server.
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6. Starting the import data process
For more information about these options, please refer to our Online help.

Processing imports
Click the Finish button to start importing data. The complete process includes all previously configured
steps, and can take some time depending on your selections.
Note: Import options may be saved in a batch file, so that the import process can be automated and
scheduled at your convenience. See Automating and scheduling the collection of data and other actions .

Promodag Reports
1.
2.
3.
4.
5.

Imports recipients from the directory/the Office 365 tenant,
Creates message tracking files (Office 365),
Imports message tracking data,
Imports IIS data,
Imports storage size data.

Each operation finishes off by displaying an operation report dialog box. A trace file is also recorded and
can be used to troubleshoot possible errors or resolve various configuration issues. If you need to do so,
use the Consult Trace Files option to view the content of the last trace files.

Chapter 3 - Using reports

A - How to find your way?
Promodag Reports includes about 80 report templates that you can use to create your own custom
reports.
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1. Report templates
To open a template, you can either
1.
2.

Use the Templates menu.
Use the Report Explorer, on the left pane of the main window. It can be hidden or displayed by
clicking the

icon.

Before you start using the product, we suggest you to open our List of reports templateson our website.
Templates are grouped in categories, such as Storage, Mailbox Content or Billing for example. These
categories appear as main nodes in the Report Explorer and they cannot be modified. The names of these
categories are meant to help you find your way among templates. Each entry comes with a short
description.
Graphical reports are distinguished from tabular reports in the Templates menu as well as in the Report
Explorer by a specific
icon.

EXAMPLE
•
•

A template that would let you generate a report showing the size of public folders is likely to be
found in the category called Storage. If you open that category, you will find a template called
Public Folder Storage Information.
Should you likewise need to produce a report showing the top 10 email senders in your
organization, open the category called Mailbox Traffic. If you open that category, you will find a
template called Mailbox by Traffic Level.

2. Canned reports (Favorites)
The software is delivered with a number of ready-to use custom reports, for example: 'What are the 10
largest mailboxes'. These canned reports are available on the Favorites menu and they are grouped in
custom categories based on the main use cases of the product: Traffic Analysis and SLA Reporting,
Compliance, Capacity Planning and Exchange Migrations, Chargeback.
You can rename these sample reports or delete them at will. You can also rearrange the existing tree, or
create your own hierarchy in the Favorites menu.

B - Creating new custom reports
1. Selecting a valid reporting period
Period tab and data sources
Many report templates include a Period tab: all traffic reports, OWA and ActiveSync reports and some
reports on storage size. These templates share in common the use of data that must previously be
imported into the database.

What reporting period can be selected?
The time range you select in the Period tab must always be covered by matching data imports.
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EXAMPLE
Requesting a report on mailbox traffic for January until June last year will not work if you have only started
to import message tracking files of this year. If you do so, you will get a message to inform you that 'No
data was found for the selected period'.
Note: In evaluation mode, it is only possible to import 15 days of data: as a consequence, it is also only
possible to report on that same time period.
For more information on the limitations of the evaluation mode, see "Evaluating the product", on page 10.

2. Selecting objects or recipients
Selection tab and directory objects
All report templates include a Selection tab. This feature lets you include directory objects or recipients
whose traffic, content or storage must be displayed in the report.
A directory object can be a server, or an Exchange database; it can also be a recipient, for example a
mailbox or a distribution group.
Directory objects are imported with most of their attributes into the database, which lets you select them
using the attribute of your choice in the Selectiontab.

EXAMPLE
Mailboxes can be selected by country, or department, or company.

What objects can be selected?
Each report template focuses on a specific aspect of the messaging system. As a consequence, the
available Selection tabs differ depending on the scope of the report template.

EXAMPLE
A report template focused on mailbox traffic will let you select mailboxes, whereas a report template
dedicated to public folder content will let you select public folders only.
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Some transverse templates like Find Specific Messages, that is focused on messages, will let you select
different recipient types: mailboxes, or distribution groups, or public folders.

Excluding objects
Click the
same principle.

button to exclude directory objects or recipients from the report using the

3. Selecting correspondents
The 'correspondents' are those who sent messages to, or received messages from your selection of
recipients.
The vast majority of traffic report templates include a Correspondents tab. This feature lets you filter the
correspondents of the recipients previously selected in the Selection tab.
The most usually available option allow you to select correspondents by address type.
•
•
•

To select all internal correspondents, select: Correspondent type, Is any of, Internal.
To select all external correspondents, select: Correspondent type, Is any of, External.
To select all application agents, devices etc. that have an SMTP address but no mailbox, select:
Correspondent type, Is any of, Unidentified local recipient.

EXAMPLE
You may want to select correspondents from specific SMTP domains, for example the gmail.com, yahoo
and hotmail correspondents of the selection of mailboxes you have just checked in theSelection tab.

4. Selecting the right detail level
Many report templates include a Content tab with Detail level options. This feature is aimed at focusing
the report at different levels.

EXAMPLE
A report template on mailbox content such as General Mailbox Content includes three detail levels:
Mailbox, Folder, Item. If you select Mailbox, it will only display the mailbox name and a total item count
and size, whereas it would display a list of items within the mailboxes you selected if you had selected
Item.

22

Getting started with Promodag Reports

The same principle applies to all other templates that have a Detail level option: the more you go down the
list, the more detailed the report will be.

C - Saving custom reports
1. Saving and reloading a report with its options
To create and save a new custom report, select a report template from the Templates menu, and select
the options of your choice. You may also record specific selection settings separately if you plan to reuse
them in other reports.
•
•

Click the Save options button at the bottom of the report interface to save the option file.
Click the Load options button to reload it once the report interface is open.

2. Adding a report to the Favorites
Make your own custom reports available in the Favorites menu by selecting the 'Add to Favorites menu'
check box before saving them.
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D - Previewing, exporting, publishing and e-mailing reports
A report can either be previewed on screen, exported to various file formats, published to a SharePoint
document library or automatically attached to an e-mail and sent to a recipient of your choice.

1. Previewing reports
The default output is 'Screen'. It is recommended to use it when generating a report for the first time, so
that you can reload your options and adapt them if necessary.

2. Exporting reports
Use the File > Export Report option once the report is available for preview on screen.

Available formats
Reports can be exported to different file formats: CSV, PDF, XLS, XLSX, RTF, HTML, MHT.

3. Publishing reports
You can export reports
•
•

To your Intranet: Export reports as PDF or HTML files to the web root of your intranet.
To a public folder: Select the 'Exchange folder' output option.
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•

To SharePoint: Select the SharePoint output option. The default server and document library can
be selected in the Export tab of Tools > Options.

4. E-mailing reports
All reports can be emailed to specific recipients, by selecting the Email output option. Moreover, the
Compose For... tab allows you to email reports to all mailboxes selected in the report.

D - Support
This page provides an overview of Promodag’s support resources for our existing users and newcomers
evaluating the product. Alongside a suite of on-line resource tools focused on addressing common user
issues, we also provide a dedicated support system.

Self-help resources
The quickest starting point for your support needs is to consult our on-line resource tools on our support
page (https://www.promodag.com/support).

Submitting a Support Request
Our customer support team will respond to requests from both users evaluating the product and
customers with a valid maintenance contract.
Support requests can be submitted either …
•
•
•

Via our contact form: https://www.promodag.com/contact-us/
Via email at support@promodag.com or use Help > Technical Support Request from the product’s
menu system.
Or by phone: +33 1 45 73 49 96 or Toll Free (from USA only): (844) 311-5003.

We normally respond within 2 hours, but please allow 24 hours for us to respond to account for
differences in international time zones.
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