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About this guide
This guide is designed to provide a quick introduction to Promodag Reports for Microsoft Exchange, and
it describes steps from getting started to producing the first report.

For more details about specific features of Promodag Reports, please refer to the online Help system.

Introducing Promodag Reports

Promodag Reports is an advanced and cost-effective reporting tool that enables Exchange Server
administrators and ITmanagers to obtain valuable information about all aspects of their email system.

With its powerful and easy-to-understand features, Promodag Reports produces comprehensive
reports that you can rely on to ensure better security, business continuity, and to improve Exchange
organization performance.

Promodag Reports is easy to install and configure. Reports use native Exchange server data sources;
so, there is nothing to install on the server. The product collects and stores the necessary data into a
SQL Server Express LocalDB or an SQL Server database. You can choose from over 80 ready-made
report templates and publish reports to various destinations in different formats. All operations can be
easily automated and scheduled so you can set up the product and forget about it.
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How does it work?

On-Premises environments: schematic system lay-
out
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Office 365 environments: schematic system lay-
out
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Chapter 1 - Prerequisites

A - Microsoft Exchange Server requirements

Promodag Reports supports Microsoft Exchange Server 2010 to Exchange Server 2019 andOffice 365
(Exchange Online). It is possible to use the product with a mix of different versions of Exchange.

You do not need to install anything on the Exchange Server, or to modify anything in
your Exchange organization.

B - Computer requirements

The 'Promodag computer' is the computer on which Promodag Reports is installed.

Promodag Reports can be installed on amachine running a supported desktop or server operating sys-
tem. It is not recommended to install it on a strategic element of your environment, for example a GC
server or an Exchange server.

1. Common computer hardware and software requirements
l Computer: A Core i3 Intel Processor with 4 GB of RAM or an equivalent Virtual Machine.
l Supported operating systems: A 64-bit version of Windows 10/Windows Server 2016 toWin-
dows 11/Windows Server 2022. Core versions of Microsoft Windows Server are not supported.

l TheWindows Remote Management (WS-Management) service should be enabled and set to
Automatic (Delayed Start).

2. Specific requirements for Office 365

Internet access

If your Exchange organization is Hybrid or full Office 365, the computer must have access to the Inter-
net and the endpoints whose list is regularly updated by Microsoft must be reachable for customers
using Office 365 plans, including Government Community Cloud (GCC).

C - Creating a Promodag account for an On-Premises environment

The 'Promodag account' is the service account that is used to start Promodag Reports. It should be cre-
ated alongwith a mailbox.

1. Create a user account and a mailbox

Create a new user and amailbox using the Exchange admin center (EAC) and give it a meaningful
name, for example 'ServicePromodag'. The password for this user should never expire.

2. Add the user to the local Administrators group

Follow these steps to add the Promodag user to the local Administrators group:

1. Open Computer Management.
2. In the console tree, click Groups (Computer Management\System Tools\Local Users and

Groups\Groups).
3. Right-click the Administrators group, click Add to Group, and then click Add.
4. In the Select Users, Computers, or Groups dialog box, type the name of the Promodag user,

and then clickOK.

https://docs.microsoft.com/en-us/microsoft-365/enterprise/urls-and-ip-address-ranges?view=o365-worldwide
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3. Assigning the appropriate roles to the Promodag user

Exchange 2013/2019:
l Click Admin > Exchange to open the Exchange Admin Center.
l Click Permissions and open the Admin role tab and then click Add +.
l In the New role groupwindow that appears, enter a name and a description for this new group,
for example 'Promodag Reports'.

l In Roles, click Add + and select the ApplicationImpersonation role.
l Click+ to add the Promodag user.
l Click Save.
l Add the Promodag user to the Recipient Management and Public Folder Management role groups.
l Click Save.

Exchange 2010:

Add the user account into the Organization Management and Hygiene Management role groups using
Active Directory Users and Computers tool (ADUC). You will find these groups in the Microsoft
Exchange Security Group Organizational Unit.

D - Certificate-based authentication to Office 365

If your company's security policy doesn't allow you to use an account and password to access Office
365 or if you use MFA, you can skip theUser-based authenticationmode and use the Certificate-
based authenticationmode instead. You can make this choice in the Configuration Wizard or in the
Office 365 configuration tab of Tools > Options.

1. Create the certificate and the Promodag Reports Application

Please follow these steps to create the Promodag Reports Application, the certificate, register them in
Microsoft Entra ID and create a dedicated role group in Exchange Admin Center:

Prerequisites

The computer’s operating version must be greater than or equal to Windows 10/Windows Server
2016. Microsoft PowerShell 7 or higher is required.

The ExchangeOnlineManagement andMicrosoft.Graph PowerShell modules should be installed on the
computer. It they are not, please proceedwith these steps:

1. Click and search for PowerShell > Windows PowerShell 7 and run it as administrator.

2. Install the ExchangeOnlineManagement module: Install-Module ExchangeOnlineManagement
-Scope AllUsers

3. Install the Microsoft.Graph module: Install-Module Microsoft.Graph -Scope AllUsers

Create the certificate and application using the provided script

These steps will enable you to create a self-signed certificate, an application in Microsoft Entra ID to
access your tenant, and a role group in Exchange Admin Center.

1. The script is delivered by default in the C:\Users\Public\Documents\Promodag\Reports\ dir-
ectory but you can use it from a different location.

2. Run the script: .\CreateRepexRBACApp.ps1
3. Enter certificate password at prompt andwrite it down.
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4. 4. The script will proceed, and you will be prompted to sign-in to Office 365 to create the role
group and grant it the relevant permissions. Use a Global Administrator account.

5. 5. A certificate valid for two years has now been created in the script directory with the name "
RepexRBACAppCertificate.pfx". The application has been created in Microsoft Entra ID with the
name "Promodag Reports RBAC Application", a role groupwith the name “Promodag Reports
RBAC Role Group” has been created in Exchange Admin Center, a service principal object has
been created for this new application and it has been added as a member of this new role group.

6. 6. The script displays the summary information to be used in Promodag Reports: Application ID
and certificate path, plus a link (Authorization URL) to connect to Microsoft Entra ID and author-
ize the newly created application. This information is then saved into a file in the current dir-
ectory.

2. Authorize this new application in Microsoft Entra ID

Grant admin consent

1. Paste the URL displayed in a web browser to connect to Microsoft Entra ID. Sign in using a
Global Administrator account. The Promodag Reports RBAC Application | API permissions page
opens.

2. ClickGrant admin consent for <name of your Office 365 tenant>.
3. Review the permissions granted to the application (see the help file for detailed information).

Optional: You can delete the self-signed certificate and use your own if you prefer. See the help file on
how to do it.

3. Apply "Promodag Reports RBAC Application" settings to Promodag Reports

Please make sure that you have retrieved the following information the first step:

l Application ID,
l Certificate path,
l Certificate password.
1. In Promodag Reports, go to Tools > Options, Office 365 configuration.
2. Select Certificate-based authentication.
3. Enter the Application ID, Certificate file path and Certificate password in the corresponding

fields.
4. Click the Check validity link to verify the certificate expiration date.  
5. Click the Check connection links to verify that Promodag Reports can connect to your tenant

using the Microsoft Entra ID application and the certificate.



Getting started with Promodag Reports

10

4. If you have already created the Promodag Reports application and wish to grant it min-
imum permissions

Step 1 Remove the Global Reader role
1. Open the Azure AD portal at https://portal.azure.com/.
2. Under Manage Microsoft Entra ID, click View.
3. On the Overview page that opens, under Manage, select Roles and administrators.
4. In the search field, enter the name of the Global Reader role.
5. Select the Global Reader role.
6. Remove the Promodag Reports Application from the assignments.

Step 2: Retrieve the Promodag Reports Microsoft Entra ID application identifiers
1. Open the Azure AD portal at https://portal.azure.com/.
2. Under Manage Microsoft Entra ID, click View.
3. On the Overview page that opens, under Manage, select Enterprise applications.
4. Uncheck Application type ==Enterprise Applications next to the Search by application name

field.
5. In the search field, enter the name of the existing custom Promodag Reports application

(default: “Promodag Reports Application”).
6. In Properties, write down the Application ID andObject ID. This will be used later.

Step 3: Create an Exchange Admin role group for Promodag Reports
1. Go to Microsoft 365 admin center, Exchange admin center.
2. Expand Roles on the left and click Admin roles.
3. Click Add role group.
4. In the New role groupwindow that appears, enter “Promodag Reports role group” as the name

of the role group alongwith a description.
5. ClickNext.
6. In the Add permissions window, select View-Only Recipients andMail Recipients.
7. ClickNext.
8. Role group assignment will be performed in the next step. So, clickNext again then Add role

group to create the Role group.

Step 4: Create Management Role Assignment

In a PowerShell 7 window, connect to Exchange Online PowerShell.

Create a service principal object for the Promodag Reports Microsoft Entra ID application

$SP = New-ServicePrincipal -AppId <appId from step 2> -ObjectId <Object id from step 2> -Dis-
playName "SP for Promodag Reports Application"

Add the service principal as a member of the custom role group:

Add-RoleGroupMember -Identity “Promodag Reports role group” -Member $SP.Identity

Then go to "Apply "Promodag Reports RBAC Application" settings to Promodag Reports", on page 9.
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E - User-based authentication to Office 365

Promodag Reports can collect information from your Office 365 tenant through a user with specific per-
missions. It is possible to use an existing account; however, we recommend creating a dedicated user
for that purpose. This account must not be subject to multi-factor authentication (MFA). You can make
this choice in the Configuration Wizard or in the Office 365 configuration tab of Tools > Options.

1. Create a user account for Promodag Reports

l Sign in to Microsoft 365 Admin Center as an administrator.

l ClickUsers > Active users and select Add a user.
l Choose a Display name and a user name, for example 'Promodag user'.

2. Assigning the appropriate roles to the Office 365 Promodag user
l Sign in to Microsoft 365 Admin Center as an administrator.
l Click Admin > Exchange to open the Exchange Admin Center.
l Click Roles > Admin roles and then click Add role group.
l In the Set up the basics window that appears, enter a name and a description pour this new
group, for example 'Promodag Reports Role Group'.

l In Permissions, select the Mail Recipients and View-Only Recipients roles.
l In Admins, add the Promodag user.
l Click Add role group.

3. Allowing reports on mailbox content

Some additional conditions must be met to allow Promodag Reports to retrieve the content of mail-
boxes when running the reports of the Mailbox Content category:

l The Promodag user must be assigned a user mailbox and therefore an Office 365 license.
l Grant the ApplicationImpersonation role to the Office 365 Promodag user. To assign this role,
please edit the role group created at the previous step, open the Permissions tab and add the
ApplicationImpersonation role.

l If you use Modern Authentication with Office 365, authorize Promodag Reports in Microsoft Entra
ID. To perform this task, open the application, go to Tools > Options, test your connection in
Office 365 configuration and follow the instructions provided .

Note: In February 2024, Microsoft announced that the ApplicationImpersonation role would be
removed from the Exchange Online user interface in May 2024, while its complete removal is
scheduled for February 2025. The only solution will be to switch to Certificate-based authen-
tication.

F - SQL Server requirements for Promodag Reports Enterprise edition

1. Supported versions

Promodag Reports supports all editions of Microsoft SQL Server from SQL Server 2008 to SQL Server
2022.

SQL Server Express (2008 to 2022)may be usedwith Promodag Reports Enterprise edition; however,
database size is limited depending on the version (10 GB for SQL Server 2008 R2/2022 Express and 4
GB for SQL Server 2008 Express).
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2. Permissions

The Promodag account must have been granted the db_owner role on the Promodag Reports data-
base. It must also have the public and db_datareader roles on the TEMPDB database.

The ability to create databases requires specific SQL permissions (CREATE DATABASE).
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Chapter 2 - Getting started

A - Evaluating the product

You may evaluate Promodag Reports for a period of up to 45 days from first installation. The only
other limitation is that your reports on e-mail traffic or OWA and Active Sync activity can only cover a
maximal period of 15 consecutive days.

You can indeed only import up to 15 consecutive days of Exchange message tracking files or IIS log files
in evaluation mode, which explains the latter restriction.

There is no limitation to the number of report templates you can use - all options being available - dur-
ing your 45-day evaluation period.

B - Installing the application

Note: Please make sure that your workstation complies with all points listed in Workstation
requirements before proceeding with the installation process.

Installing Promodag Reports
a. Go to https://www.promodag.com/ to download Promodag Reports.
b. Choose a temporary directory to store the installation package.
c. Double-click the installation package to start the installation process.
d. Simply follow the instructions of the installation wizard.

For more information about default paths for installation and settings, see the help file.

C - Initial setup

Starting the application

From the Start Menu, select Programs > Promodag> Promodag Reports 14 to start Promodag Reports.

You will first be prompted to select the type of Exchange organization you wish to analyze.

The configuration wizard provides a user-friendly interface to start with Promodag Reports. It auto-
matically appears when you run the software for the first time and guides you through the first con-
figuration of the product.

https://www.promodag.com/
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It provides you with instructions on:

1. Evaluating or licensing the product,
2. Creating a new Promodag Reports database,
3. Discovering the on-premise Exchange servers,
4. Configuring a connection to your Office 365 tenant (Hybrid deployment),
5. Selecting data sources to import depending on the reports you need:

a. Message tracking files,
b. Internet Information Services log files,
c. Storage size:

l Mailbox size,
l Database size,
l Mailbox count per database,
l Public folder size,

6. Starting the data import process.

1. Evaluating or licensing the product

This window lets you carry on using Promodag Reports in evaluation mode or apply a valid license to the
database.
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2. Creating a new Promodag Reports database

Promodag Reports requires a database in order to store the data it collects from Microsoft Exchange. It
will then use this data to generate reports. It is possible to create multiple databases.

To create a new database, select the type of your messaging environment, and the type of database
that best suits your needs.

Exchange Organization type
l On-Premises: Administrators run the messaging system on their own servers, in their own com-
pany.

l Hybrid deployment: This is a mixed environment: part of the messaging system is hosted in an
Office 365 tenant, but the company has kept some Exchange servers on-premise.

l Office 365: The messaging system is hosted by Microsoft. Microsoft Exchange Online is an email,
calendar and contacts solution delivered as a Cloud service and it is part of the Office 365 suite.

Select On-Premises or Hybrid deployment depending on your messaging environment.

Database type

SQL Server Express LocalDB
l Best suited for small Exchange organization.
l Usable with all editions of Promodag Reports.
l The physical size limit set by Microsoft to SQL Server Express LocalDB database files is 10 GB
(10,240 MB).

l Microsoft SQL Server LocalDB 2017 is installed with Promodag Reports.
l Nomulti-user access.
l The database file should be located on the same computer as Promodag Reports.
l Easy upgrade to SQL Server.

Microsoft SQL Server
l Best suited for medium or large Office 365 tenants (more than 1,000 mailboxes).
l Requires the Enterprise edition of Promodag Reports.
l The database size is only limited by disk space on the SQL Server.
l Multi-user access.
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l Performance is determined by the power of the SQL server.
l An additional SQL Server license (not provided)may be required.

The SQL Server Express LocalDB format is recommended for evaluating the product, for it does not
require anything else.

Choose a name for your database. For SQL, enter the name of the server without \\, and then the
name of the instance if applicable.

ClickNext to confirm your settings andmove on to the next step.

3. Configuring a connection to your Office 365 tenant

If you have subscribed to an Office 365 GCC High or DoD plan, choose your Office 365 Cloud from the
drop-down list.

You can choose between two sets of settings that allow Promodag Reports to access Office 365
resources:

l Certificate-based authentication (recommended): Promodag Reports must be published
as an application in Microsoft Entra ID. In this context, the permissions are those that have been
granted to the application and not to a user. To create this standard Promodag Reports Applic-
ation and the linked certificate, see "Certificate-based authentication to Office 365", on page 8.
To create a custom Azure application manually, see the help file.
l Pros:

l No specific user account andmailbox are required, which completely eliminates the
problem of password expiration.

l No Office 365 license is required.

l Import of Office 365 licenses.
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l Cons: None.
l User-based authentication: The permissions are those granted to the PromodagOffice 365
account. For more information about the required permissions, see User-based authentication to
Office 365.
l Pros: Granting permission is straightforward.
l Cons:

l An Office 365 license for a user andmailbox are required.
l If the password regularly expires, it must be updated in Promodag Reports.
l The ApplicationImpersonation role is about to be deprecated (February, 2025) and it
will no longer be possible to run reports on mailbox and public folder content.

l This mode is incompatible with MFA.

l No import of Office 365 licenses.

ClickNext to confirm your settings andmove on to the next step.

4. Selecting data sources to import depending on the reports you need

Message tracking files

Promodag Reports will use this data source to generate traffic reports. Select the servers whose mes-
sage tracking files will be imported. The default date range covers the last 7 days.

You may specify the period to be imported:

l Import from: Date of the first message tracking file to import.
l To: Date of the last message tracking file to import.
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ClickNext to confirm your settings andmove on to the next page. The location of message tracking
files will be tested on each selected server.

IIS log files

Promodag Reports will use this data source to generate OWA and ActiveSync reports. Select the servers
whose IIS log files will be imported. The default date range covers the last 7 days.

You may specify the period to be imported:

l Import from: Date of the first message tracking file to import.
l To: Date of the last message tracking file to import.

ClickNext to confirm your settings andmove on to the next page. The location of IIS log files will be
tested on each selected server.
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Storage size

Promodag Reports will use this data source to generate storage size reports. Select the servers whose
storage size (mailbox and public folder size, Exchange database size) will be imported.

ClickNext to confirm your settings andmove on to the next page. The location of mailbox and public
folder databases will be tested on each selected server.

5. Starting the import data process

For more information about these options, please refer to our Online help.
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Processing imports

Click Finish to start importing data. The complete process includes all previously configured steps, and
can take some time depending on your selections.

Note: Import options may be saved in a batch file, so that the import process can be automated
and scheduled at your convenience. See Automating and scheduling the collection of data and
other actions .

Promodag Reports

1. Imports recipients from the directory/the Office 365 tenant,
2. Creates message tracking files (Office 365),
3. Imports message tracking data,
4. Imports IIS data,
5. Imports storage size data.

Each operation finishes off by displaying an operation report dialog box. A trace file is also recorded and
can be used to troubleshoot possible errors or resolve various configuration issues. If you need to do so,
use the Consult Trace Files option to view the content of the last trace files.
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Chapter 3 - Using reports

A - How to find your way?

Promodag Reports includes about 80 report templates that you can use to create your own custom
reports.

1. Report templates

To open a template, you can either

1. Use the Templates menu.
2. Use the Report Explorer, on the left pane of the main window. It can be hidden or displayed by

clicking the icon.

Before you start using the product, we suggest you open our List of reports templates on our website.

Templates are grouped in categories, such as Storage,Mailbox Content or Billing for example.
These categories appear as main nodes in the Report Explorer and they cannot be modified. The names
of these categories are meant to help you find your way among templates. Each entry comes with a
short description.

Graphical reports are distinguished from tabular reports in the Templatesmenu as well as in the
Report Explorer by a specific icon.

EXAMPLE

l A template that would let you generate a report showing the size of public folders is likely to be
found in the category calledStorage. If you open that category, you will find a template called
Public Folder Storage Information.

l Should you likewise need to produce a report showing the top 10 email senders in your organ-
ization, open the category calledMailbox Traffic. If you open that category, you will find a tem-
plate called Mailbox by Traffic Level.

2. Canned reports (Favorites)

The software is delivered with a number of ready-to use custom reports, for example: 'What are the 10
largest mailboxes'. These canned reports are available on the Favorites menu and they are grouped in
custom categories based on the main use cases of the product: Traffic Analysis and SLA
Reporting, Compliance, Capacity Planning and Exchange Migrations, Chargeback.

You can rename these sample reports or delete them at will. You can also rearrange the existing tree or
create your own hierarchy in the Favoritesmenu.

B - Creating new custom reports

1. Selecting a valid reporting period

Period tab and data sources

Many report templates include a Period tab: all traffic reports, OWA and ActiveSync reports and some
reports on storage size. These templates share in common the use of data that must previously be
imported into the database.
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What reporting period can be selected?

The time range you select in the Period tabmust always be covered by matching data imports.

EXAMPLE

Requesting a report on mailbox traffic for January until June last year will not work if you have only star-
ted to import message tracking files of this year. If you do so, you will get a message to inform you that
'No data was found for the selected period'.

Note: In evaluation mode, it is only possible to import 15 days of data: as a consequence, it is
also only possible to report on that same time period.

For more information on the limitations of the evaluation mode, see Evaluating the product.

2. Selecting objects or recipients

Selection tab and directory objects

All report templates include a Selection tab. This feature lets you include directory objects or recip-
ients whose traffic, content or storage must be displayed in the report.

A directory object can be a server, or an Exchange database; it can also be a recipient, for example a
mailbox or a distribution group.

Directory objects are imported with most of their attributes into the database, which lets you select
them using the attribute of your choice in the Selection tab.

EXAMPLE

Mailboxes can be selected by country, or department, or company.
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What objects can be selected?

Each report template focuses on a specific aspect of the messaging system. As a consequence, the avail-
able Selection tabs differ depending on the scope of the report template.

EXAMPLE

A report template focused on mailbox traffic will let you select mailboxes, whereas a report template
dedicated to public folder content will let you select public folders only.

Some transverse templates like Find Specific Messages, that is focused on messages, will let you select
different recipient types:mailboxes, or distribution groups, or public folders.

Excluding objects

Click the button to exclude directory objects or recipients from the report using
the same principle.

3. Selecting correspondents

The 'correspondents' are those who sent messages to, or receivedmessages from your selection of
recipients.

The vast majority of traffic report templates include a Correspondents tab. This feature lets you filter
the correspondents of the recipients previously selected in the Selection tab.

The most usually available option allow you to select correspondents by address type.

l To select all internal correspondents, select: Correspondent type = Internal.
l To select all external correspondents, select: Correspondent type = External.
l To select all application agents, devices etc. that have an SMTP address but nomailbox, select:
Correspondent type = Unidentified local recipient.

EXAMPLE
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You may want to select correspondents from specific SMTP domains, for example the gmail.com, yahoo
and hotmail correspondents of the selection of mailboxes you have just checked in the Selection tab.

4. Selecting the right detail level

Many report templates include a Content tab with Detail level options. This feature is aimed at focus-
ing the report at different levels.

EXAMPLE

A report template on mailbox content such as General Mailbox Content includes three detail levels: Mail-
box, Folder, Item. If you select Mailbox, it will only display the mailbox name and a total item count and
size, whereas it would display a list of items within the mailboxes you selected if you had selected Item.

The same principle applies to all other templates that have a Detail level option: the more you go down
the list, the more detailed the report will be.

C - Saving custom reports

1. Saving and reloading a report with its options

To create and save a new custom report, select a report template from the Templates menu, and select
the options of your choice. You may also record specific selection settings separately if you plan to reuse
them in other reports.

l Click the Save options button at the bottom of the report interface to save the option file.
l Click the Load options button to reload it once the report interface is open.

2. Adding a report to the Favorites

Make your own custom reports available in the Favorites menu by selecting the 'Add to Favorites
menu' check box before saving them.
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D - Previewing, exporting, publishing and e-mailing reports

A report can either be previewed on screen, exported to various file formats, published to a SharePoint
document library or automatically attached to an e-mail and sent to a recipient of your choice.

1. Previewing reports

The default output is 'Screen'. It is recommended to use it when generating a report for the first time,
so that you can reload your options and adapt them if necessary.

2. Exporting reports

Use the File > Export Report option once the report is available for preview on screen.

Available formats

Reports can be exported to different file formats: CSV, PDF, XLS, XLSX, RTF, HTML, MHT.

3. Publishing reports

You can export reports

l To your Intranet: Export reports as PDF or HTML files to the web root of your intranet.
l To a public folder: Select the 'Exchange folder' output option.
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l To SharePoint: Select the SharePoint output option. The default server and document library can
be selected in the Export tab of Tools > Options.

4. E-mailing reports

All reports can be emailed to specific recipients, by selecting the Email output option. Moreover, the Indi-
vidual reports tab allows you to email reports to all mailboxes selected in the report.

Support

This page provides an overview of Promodag support resources for our existing users and newcomers
evaluating the product. Alongside a suite of on-line resource tools focused on addressing common user
issues, we also provide a dedicated support system.

Self-help resources

The quickest starting point for your support needs is to consult our on-line resource tools on our sup-
port page (https://www.promodag.com/support).

Submitting a Support Request

Our customer support team will respond to requests from both users evaluating the product and cus-
tomers with a validmaintenance contract.

Support requests can be submitted either …

l Via our contact form: https://www.promodag.com/contact-us/
l Via email at support@promodag.com or use Help > Technical Support Request from the product’s
menu system.

l Or by phone: +33 1 45 73 49 96 or Toll Free (from USA only): (844) 311-5003.

We normally respondwithin 2 hours, but please allow 24 hours for us to respond to account for dif-
ferences in international time zones. Our office hours are 10 AM to 7 PM UTC+1 (Paris), Monday to Fri-
day.

https://www.promodag.com/support/
https://www.promodag.com/support/
https://www.promodag.com/contact-us/
mailto:support@promodag.com?subject=Support request for PROMODAG Reports
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